If you receive an error message, create a support ticket and tell us what happened, what device you tried to install the app on (e.g. iPhone 4s, HTC model number, Samsung Galaxy etc)


Supported devices:


  • iPhone 4 and newer
  • iPad 2, iPad Mini and newer
  • Any Android devices running 2.2 and later operating systems

We are currently developing for Blackberry and Windows Mobile.